SizeWell not running for Finder on computer restart

NeeWee shared this problem 10 years ago
Solved

So glad I found your program (SizeWell). I love that the default application Zoom is unaffected, and only applied with modifier keys, controlled from a preference pane. All lovely and discrete. Thank you for it.


Have found a problem though. I am running Snow Leopard (10.6) on a 13" MacBook Pro and SizeWell doesn't seem to be active upon restarting the computer. After everything has started up however, if I Relaunch Finder by Ctrl-Alt clicking on it in the dock, SizeWell then works. I assume this is like when you initially enable sizewell, and are told that applications need to be relaunched before it takes effect. Presumably SizeWell would have to be loaded before Finder loads in order for it to work with Finder automatically on computer restart (without a manual Finder relaunch).

Comments (3)

photo
1

I am happy you enjoy SizeWell, thanks for using it!


Sadly, this behavior is because of SIMBL, the plugin architecture SizeWell uses. SIMBL loads after the Finder on startup, because of OS X. So, this affects all SIMBL plugins that effect the Finder. Currently, the only solution is to relaunch the Finder after startup, although, to make this easier, an AppleScript or Native application can be written to relaunch the Finder, then be set as a login item, making it happen automatically every launch. Other SIMBL plugins like TotalFinder do this. I apologize for not being more clear about this behavior in the description, etc. In fact, I think I removed it from the description in the 0.7 beta 1 release, my mistake.


So, this is one of the things on my to-do list for a 1.0 release, and really, will be quite simple. I just haven't gotten around to it yet and have been busy with other parts of my life lately.


You can expect this added functionality in the next release, but I can't give any honest timeline on when I will get this done. Although, suggestions and comments just like the one you just gave tend to help the motivation. :)


Thanks,


- Pico Mitchell


PS. I will mark this as solved and comment about it on here so you can be notified when I have this feature ready for release.

photo
1

This has been addressed in SizeWell 0.8 beta, which was just released.


http://sizewellplugin.com

photo
1

Marking this problem as solved...