Relinking Spanned Media to iTunes

Jody Fletcher shared this problem 6 years ago
Known

Hi all,


Really annoyed.


Have been having issues with my wife's iPad, but that's for another day.


Right now, after following Apple Supports recomendations for fixing the problem with the iPad the links from the iTunes library to the spanned media are all broken. iTunes is being intransigently unhelpful and refusing to let me the media to the files - suggesting that a re-download all of my media from the cloud rather than, as it allowed in the past, for me to reconnect to the moved files.


I have roughly 270 Gbytes of media and just nowhere near enough room on the harddrive of my 2008 iMac to reimport all of these files.


Can anyone suggest an easy fix? I am running Mavericks and all of my apps are fully up to date


Cheers


Steve

Comments (3)

photo
1

Oh and just to clear up any confusion this is my wife Jody's computer, hence her account, but I maintain it so my sign-off


Steve

photo
1

Thanks for getting in touch.


Are these tracks in iTunes Match? If so, and they are remote tracks to stream or download now, they will need to be redownloaded. It's annoying, but I haven't found a way to get iTunes to turn a track from "remote" to "local" even if the files exist on the system without redownloading it through iTunes. I tried AppleScript and everything, but the tracks are just in a different state and need to be redownloaded to be converted to the local track state which TuneSpan can work with.


If that's not the case, and the tracks are showing up in TuneSpan, you should be able to select the tracks to span, and set the Span Location to where you know the files to exist, and then click Span and TuneSpan will not try to copy anything but will simply relink the tracks with the files that it finds in the Span Location.


If neither of those makes sense, I'll probably need to know more about what was done that created the problem.

photo
1

Actually solved the problem - had a Eureka moment in the shower - Used Time machine to go back to before I stuffed things up then used the "Option" boot on iTunes to reselect the correct - uncorrupted library - problem solved


Thans for your help