iTunes Match Hung at "Step 1: Gathering information" for Many Hours After TuneSpan Migration to Time Capsule

Nathan Ellsworth shared this question 8 years ago
Answered

Hi. I just bought TuneSpan and spanned all my music to my local Time Capsule drive. iTunes seems to work fine playing music now that the files are on the Time Capsule, but iTunes Match is NOT happy.


After I started iTunes for the first time after the span, I guess Match decided it needed to scan all my tracks again. And now it has been stuck at "Step 1: Gathering information about your iTunes library" for about 17 hours now, with the iTunes process taking 80-100% of a CPU continuously.


My original iTunes Match scan and publish time last year took about a day, but that was in copy time, not gather time.


Is this normal gather time now that all my tracks are on my Time Capsule? Is it broken? Should I restart iTunes or reboot the Mac?


Help!


Thanks

Comments (6)

photo
1

Thank you for getting in touch, I'm so sorry you're experiencing this issue with iTunes Match after using TuneSpan.


I also use iTunes Match and have not experienced any issues after spanning my music, so I am not quite certain what the issue may be. I also don't have a Time Capsule to test with, but I have tested with other network drives and it worked fine.


But, it sounds like you've spanned a lot of music, all to a network drive which is probably going to be slower transfer than a wired drive.


It also sounds like iTunes is doing SOMETHING, since its eating up all the CPU, but 17 hours is just too long.


First things first, I would in fact recommend quitting iTunes, restarting your Mac, then making sure the Time Capsule is mounted and accessible BEFORE launching iTunes. Then, let iTunes do its thing with Match and hopefully it will kick into gear and get done what it needs to do more quickly.


If not, get back to me and we can try to figure out some other options, but, as I said I don't have the exact same setup as you, so I am not sure if this is a consistent issue, or just a random fluke.

photo
1

Unfortunately, after a reboot, iTunes Match did the same thing. Here is the behavior. For Step 1 of the Match process, there is a progress bar in iTunes. Over a period of about two minutes, this bar goes to completion. During that time in the network graph of Activity Monitor, I see solid network activity, which I assume is iTunes accessing the tracks on my Time Capsule.


Then once the Step 1 progress bar is complete, iTunes appears to be doing nothing, except for the high CPU utilization.


Basically it is hung at 100% complete on Step 1, and won't go on to Step 2, which is "Matching you music with songs in the iTunes Store."


Any ideas?


Thanks

photo
1

Would it be possible for you to plug directly into the Time Capsule just this once to finish this process over the wired connection? That should allow it to get the job done more quickly.


Is there any other big network activity going on with any computer on your network that may be slowing it down? Downloads or backups, etc?


I am sorry the issue is still happening. Sadly, there is not too much I can do about how iTunes behaves. TuneSpan just moves files and updates location in iTunes, its essentially the same as if you had some music on the Time Capsule and added them to iTunes without copying them to the default media location. I am not trying to make excuses, I'm just saying with this kind of thing we are still stuck with iTunes and how it behaves, TuneSpan can't change that. And with things like this, after the span is complete, it is out of TuneSpans hands and up to iTunes.

photo
1

MacBook Air, no Ethernet :(


Besides, in Activity Monitor I see no network activity while iTunes seems hung.


Do you know if iTunes has any logging that can be enabled? I'd love to know what it is really doing. Is it possibly stuck on an entry in the iTunes XML fle that TuneSpan touched?

photo
1

Can you not plug into the Time Capsule with USB... I guess that's just for a printer? I was hoping you could connect as a normal external drive, not a network drive.


I'm not sure about extra logging for iTunes. But also, TuneSpan does not directly modify the XML library file. It just uses that to read the library contents. To set locations, TuneSpan uses the built in iTunes AppleScript command "set location" (but through more native code, "Scripting Bridge"). So, any changes made in the XML file were done by iTunes, but after TuneSpan told iTunes change a location through the proper means.


--------


Alright, I just did a search for this issue of iTunes Match getting stuck on Step 1...


Found this thread: http://forums.macrumors.com/showthrea...


The person seems to have had a similar issue and their stuff was on a network drive.


Someone suggested "turn off iTunes match, enable genius, let it finish, then turn back on iTunes match".


Sounds like that worked for some people, but others are talking about encountering other errors afterward. But, it's worth a shot in my opinion.


I'm really sorry if TuneSpan provoked this issue, I hope this trick works for you. Please let me know how it goes.

photo
1

Hey again, just wanted to check back in to see if you got it all working... did iTunes Match ever finish?