Changing Metadata not possible after Span to NAS

Michael shared this problem 6 years ago
Known

I spaned some movies from my iMac to my NAS which worked so far. But now, I'm not able to change any metadata e.g. artwork, title, etc. Of the spaned movies. I can change the information in itunes but they don't stay after clicking ok. If I reopen the details in itunes,all the previous changes on the metadata are gone. I'm running the latest versions of Tunespan and iTunes.

Comments (3)

photo
1

Thanks so much for getting in touch.


I haven't run into this problem myself, so it will take some investigation.


Have you done tests spanning to a connected external, do you know if this issue is affecting some tracks no matter where they are spanned, or if it only affects tracks spanned to a NAS?


Does this issue still affect the tracks if you restore them, or can you edit the metadata normally if you restore them?


I'm out of the house now, so I only have access to test stuff spanned to my internal partition or a little USB drive, and I didn't run into this problem, I was able to edit the metadata just fine.


When I get back home later on, I'll do some testing with a NAS and see if I run into the same problem.


Hopefully we can get to the bottom of this, but since the issue exists within iTunes, after TuneSpan has done its work, it is basically a bug in iTunes itself, that using TuneSpan may have exposed. I would imagine the same issue would come up if you had moved the files manually without TuneSpan.


I'll do my best to understand the issue, and try to find a solution, but this is part of the hassle of the nature of TuneSpan... It can do as much as it can, but in the end, its up to iTunes to handle everything properly. At the lowest levels, TuneSpan simply copies files and then uses iTunes AppleScript "set location" command to update track locations.

photo
1

Thank you for your quick reply! I tested a little bit the last days:


If I restore the movies to the original location in the itunes media folder I can edit the data with no problem. On a USB-Disk I have not experienced the problem.


But I recognized that the issue does not affect all movies at the same time. One time I can edit Movie A and Movie B not. The next time I can edit Movie B and not Movie A?!


However I did some further research in the Internet and found some people having a similar problem. I think that this has something to do with itunes. I only have the problem with movies which were tagged with iFlicks which writes all metadata to the file itself. I do not have problems with files which have only been edited with itunes itself. I believe that there must be a bug in itunes with writing tags to the file and the internal database.


What do you think? Were you able to reconstruct my problem?

photo
1

Thanks for getting back in touch, and doing some further testing.


I was not able to reproduce the problem on my end, I've been able to edit metadata no matter where the files are. But, I haven't extensively tested lots of files, and I've never used iFlicks myself.


But, this connection with iFlick may be important. It could be useful to get in touch with those developers as well if only files that were edited by iFlicks are having this problem. You could forward them to this thread as well. As I said before, since TuneSpan just copies files and uses the standard "set location" AppleScript, things should work just as they did before spanning in iTunes.


To me, it seems like using TuneSpan to move files may just be exposing a bug in iTunes, or possibly with how iFlicks sets metadata.