Cannot restore. All tracks skipped. Access/read/write permissions problem.

Forrest Davis shared this problem 4 years ago
Submitted

I am unable to restore. I spanned about half of my music

from my old macbook to my external, and itunes worked well that way. I bought a

newer macbook and restored it from a timemachine backup of the old one, so it

has the same half of my itunes library on it that the old one had, and those

files are stored in the same “place” in the new computer, and the other half is

still on the external. That worked. But the newer macbook drive is large enough

to hold the whole library, so I’m trying to restore all the spanned media from

my external to my (newer) macbook pro. Every track that I test-restore is

Skipped, with explanation/error “Don’t have access to necessary locations to

perform the restore. Please make sure all locations are readable and writable

and try again.”

Under the Tunespan Menu, -File Access, -Previously accessed

locations -(E.G.) Macintosh HD. I have granted access to every folder listed. The

final drop-down menu for each of those locations show the option “remove

access” which implies that tunespan has access to all of them. Also, at the bottom of each location menu it

says, in faint/faded lettering, “Readable” (with a checkmark next to it) and “Writable “ (with

an X next to it).

If you have a quick resolution to this, great. I need to clear

the external drive ASAP for another reason, so if the above issue is sticky, I

would alternately be interested to know: If I drag the whole spanned media

folder from my external onto my desktop, can I still use tunespan to re-insert

the albums into my itunes folder when we get this access issue resolved? I can

manually drag albums back from the external into my itunes music folder, but

albums that are split half-and-half between the drives make the manual process

pretty tedious and it seems like this is exactly what tunespan is supposed to

help with. (There are thousands of albums. I’m not sure how many would have to be

handled individually).

After browsing your help topics, I also decided to force

span all the tracks on the external, so they would be assigned to the Itunes

media folder on the current laptop. But the problem remained.

Please get back to me soon if possible, as I need to clear

that external drive. Thanks,

Forrest

Comments (1)

photo
1

Thanks for getting in touch. Sorry you've run into an issue.

The first thing to do is to upgrade to the newly released TuneSpan 1.3 which you should see on the Mac App Store now. http://mas.tunespan.com

I made some changes in there that should make TuneSpan request fresh file access at the beginning of the span when needed in situations like this instead of just skipping.

So, just update the TuneSpan 1.3 and then reattempt the same restore.

Please let me know how that goes. If it still doesn't work with TuneSpan 1.3, we can try some other things.